Can’t open letter

  • 1
  • Question
  • Updated 6 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I am familiar with the X and other indicators of not-yet-available letters, but encountered something new today — a very large square with an X in the middle of it, filling most of the top part of the page. The bottom shows “page 1 of 2” and “page 2 of 2.” I have tried it using Chrome, IE, and Edge browsers on my laptop, and Safari on my phone. I have tried it in the app. They all do the same thing. Help?
Photo of Debi

Debi

  • 130 Posts
  • 55 Reply Likes

Posted 6 months ago

  • 1
Photo of Christina

Christina, Employee

  • 1217 Posts
  • 276 Reply Likes
Debi, I'm so sorry for any concern or confusion caused by seeing a big "X" on George's letter. Thank you so much for letting us know so we may have the opportunity to help you and fix this issue. Regrettably, it looks like something has not gone through correctly with his letter, so I have asked our IT Team to look into this and resolve it as soon as possible. We appreciate your patience! 

This conversation is no longer open for comments or replies.